Infralution Support Forum Index Infralution Support
Support groups for Infralution products
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bootstrap app can't find activex dll.

 
Post new topic   Reply to topic    Infralution Support Forum Index -> .NET Encryptor Support
View previous topic :: View next topic  
Author Message
PaulS



Joined: 03 Jul 2013
Posts: 23

PostPosted: Mon Sep 22, 2014 8:29 pm    Post subject: Bootstrap app can't find activex dll. Reply with quote

I thought my project was going to be fine with encryptor. But I installed on a new virtual machine and find all kinds of errors. The most serious is included below. I do not register the activex control for various historical reasons, but use a .manifest file. The manifest file and dll are being installed by the setup as usual, but the encrypted version of my app is not picking it up. I have no idea how to fix this.

CurrentDomainUnhandledException: Retrieving the COM class factory for component with CLSID {897B372A-F588-4143-AA5D-3414D1DBC42E} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

The other big problem is that the installer has stopped picking up the dependencies on quite a few devexpress dlls. They are no longer being installed. I didn't see this problem on the dev machine since these are already in the gac.
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Tue Sep 23, 2014 9:35 am    Post subject: Reply with quote

I think it should be possible to use reg-free COM by specifying the active X control in the manifest for the Bootstrap executable. It sounds like perhaps your manifest is for the encrypted exe rather than the bootstrap and so is not being used?

For other dependencies you may need to either add these manually to your installer.
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
PaulS



Joined: 03 Jul 2013
Posts: 23

PostPosted: Tue Sep 23, 2014 4:44 pm    Post subject: Reply with quote

I changed the manifest setting of the bootstrap project from "Embed manifest with default settings" to the assembly manifest for the activex control and that seems to work. I didn't know you could do that.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Infralution Support Forum Index -> .NET Encryptor Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group