Infralution Support Forum Index Infralution Support
Support groups for Infralution products
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Interaction with ILS
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Infralution Support Forum Index -> .NET Encryptor Support
View previous topic :: View next topic  
Author Message
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Wed Jun 12, 2013 3:49 pm    Post subject: Interaction with ILS Reply with quote

I currently have ILS 4.6.3. Do I need to upgrade to the latest version in order to use .NET Encryptor? Do these two products interact anyhow? Thank you.
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Thu Jun 13, 2013 10:57 pm    Post subject: Reply with quote

No the two products are completely independant. I would recommend considering upgrading to Version 5 of ILS anyway because Version 5 has a lot of very useful new features - particularly if you are using authenticated licensing.
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Fri Jun 14, 2013 11:48 am    Post subject: Reply with quote

I'm evaluating .NET Encryptor now. Regarding signing the assemblies with strong names, I have a signing certificate from GoDaddy that I use to sign the downloadable installation file setup.exe. Should I use this certificate to sign the assemblies as well, or should I create another key pair file? Thank you.
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Fri Jun 14, 2013 12:37 pm    Post subject: Reply with quote

Signing using a strong name is different to signing with a certificate. You don't need a certificate to create a strong name and sign with it. Use the Signing tab in the Project Properties to create a strong name key file and sign the assembly with it. You should use the same strong name file to sign both your executable assembly (and any dlls) and the bootstrap assembly.
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Fri Jun 14, 2013 8:12 pm    Post subject: Reply with quote

When I try to build the bootstrap sample project it gives me an error code 9009. What am I doing wrong?
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Sat Jun 15, 2013 12:21 am    Post subject: Reply with quote

What gives you the error - the Visual Studio compiler? Can you provide full details of the error and when it actually occurs.
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Sat Jun 15, 2013 12:52 am    Post subject: Reply with quote

Code:
Error   1   The command "NetEncryptor "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\Bootstrapx86\..\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\Bootstrapx86\Assemblies"" exited with code 9009.

I'm using the Bootstrapx86 in VS2008. I didn't modify anything to the sample project. I just tried to build it and the error shows up.
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Sat Jun 15, 2013 1:14 am    Post subject: Reply with quote

It looks like you have copied the project from the default samples location. The problem is with the Bootstrap project pre-build event which runs .NET Encryptor to encrypt the executable. You can edit this in the Build Events tab of the Project properties.

The standard build event in the bootstrap project is:

Code:
NetEncryptor "$(ProjectDir)..\TestApp\$(OutDir)TestApp.exe" /outdir:"$(ProjectDir)Assemblies"


There are two possible causes of the error you are getting:

1. The NetEncryptor executable can not be found because it isn't in the PATH environment. To fix this you could change the build event to specify the full path to the NetEncryptor executable eg

Code:
"C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "$(ProjectDir)..\TestApp\$(OutDir)TestApp.exe" /outdir:"$(ProjectDir)Assemblies"


Note that you will need quotes around the full path because it contains spaces.

2. The path of the executable to encrypt being passed to the NetEncryptor program can't be resolved for some reason (perhaps because of the relative .. path). Instead of using the relative path you could specify the full path to the executable eg

Code:
"C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"$(ProjectDir)Assemblies"

_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Sat Jun 15, 2013 1:24 am    Post subject: Reply with quote

Well, originally I loaded the sample project from the default location and the error showed up. Then I copied it to the current location with the same result. None of them worked. Could you please try to reproduce the problem there? Thank you.
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Sat Jun 15, 2013 1:36 am    Post subject: Reply with quote

We have tested this on XP, Windows 7 and Windows 8 without issue. The most likely cause of the issue is that your Visual Studio PATH environment variable for some reason does not include the default PATH (which is changed by the .NET Encryptor installer to include the .NET Encryptor bin directory). The easiest fix for this is to change the Build Event to specify the full path to the NetEncryptor program as I described previously in 1.
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Sat Jun 15, 2013 1:46 am    Post subject: Reply with quote

I modified the pre build event as indicated, and now the error is different:
Code:
Error   1   The command ""C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\Bootstrapx86\..\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\Bootstrapx86\Assemblies"" exited with code 3.   Bootstrap
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Sat Jun 15, 2013 1:54 am    Post subject: Reply with quote

Is there more to that error message?

Try using the second fix I suggested which also specifies the full path to the executable to encrypt:

Code:
C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"$(ProjectDir)Assemblies

_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Sat Jun 15, 2013 2:08 am    Post subject: Reply with quote

This is weird. I cannot make it work.
Quote:
Error 1 The command "C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\Bootstrapx86\Assemblies" " exited with code 9009. Bootstrap
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4884

PostPosted: Sat Jun 15, 2013 2:21 am    Post subject: Reply with quote

Sorry in my last post it was missing the first quote. Which I think might be causing the error you are seeing. It should be:

Code:
"C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"$(ProjectDir)Assemblies

_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 200

PostPosted: Sat Jun 15, 2013 2:26 am    Post subject: Reply with quote

No. Different error code.
Code:
Error   1   The command ""C:\Program Files (x86)\Infralution\.NET Encryptor\bin\NetEncryptor.exe" "C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\TestApp\bin\x86\Debug\TestApp.exe" /outdir:"C:\Users\Javier\Documents\Visual Studio 2008\Projects\.NET Encryptor\Samples\VS2008\C#\Bootstrapx86\Assemblies"" exited with code 3.   Bootstrap
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Infralution Support Forum Index -> .NET Encryptor Support All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group