Infralution Support Forum Index Infralution Support
Support groups for Infralution products
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bootstrap error message in Windows 8

 
Post new topic   Reply to topic    Infralution Support Forum Index -> .NET Encryptor Support
View previous topic :: View next topic  
Author Message
Javier



Joined: 09 Oct 2009
Posts: 205

PostPosted: Fri Jun 28, 2013 3:04 pm    Post subject: Bootstrap error message in Windows 8 Reply with quote

A client is reporting this error when running my application in Windows 8. This doesn't occur in Windows 7. I emailed you the screen shot with the error. I don't know how to insert the image here. Please advise.
Quote:
"An unhandled exception (Could not load file or assembly AssemblyLoaderx86 ...) occurred while bootstrapping the application."
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4913

PostPosted: Sat Jun 29, 2013 12:06 am    Post subject: Reply with quote

The only reasons I can think that you could get that error message is if the AssemblyLoaderx86.dll is not in the same directory as the application executable or if it is a different version to the one you compiled against. Is it possible that the user has removed the AssemblyLoaderx86.dll or copied your application executable elsewhere without also copying the dll.

We test under Windows 8 so I don't think it is a windows 8 issue - but it would be worth testing your own installer to check that it is deploying things correctly under windows 8.
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 205

PostPosted: Sun Jun 30, 2013 1:27 am    Post subject: Reply with quote

The AssemblyLoaderx86.dll is installed in the same directory of the application. The following is the response from my installer tech support:
Quote:
The fact that your program doesn't work on the Windows 8 system, is probably due to you not installing AssemblyLoaderx86 as a global assembly, but only as a private assembly.

The Windows 8 Bootstrap error message indicates that on that system at least, Windows is trying to find AssemblyLoaderx86 in the GAC.

My guess is that on your own Windows 7 system, AssemblyLoaderx86 is already installed in the GAC, so you don't notice the problem there.

I'm confused about this GAC and global versus private assembly. I haven't seen anything of this in the help file. Could you please clarify if there's anything useful in the above comments? Thank you.
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4913

PostPosted: Sun Jun 30, 2013 11:46 pm    Post subject: Reply with quote

The GAC is the Global Assembly Cache - it enables a DLL assembly to be shared rather than having to be installed next to each executable that uses it. We don't install the AssemblyLoaderx86 DLL in the GAC - so I don't think that this at all likely to be the issue.

Have you installed your application on a clean (non-development) Windows 8 machine yourself and seen this error?
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Javier



Joined: 09 Oct 2009
Posts: 205

PostPosted: Mon Jul 01, 2013 12:46 am    Post subject: Reply with quote

No, I haven't. My development computer has Windows 7. I will get Windows 8 to do the testing.
Trying to find an answer in Google I found out that Windows 8 doesn't come with .NET Framework 3.5, which is the target Framework of my application. I wonder if this could be the problem.
http://www.askvg.com/how-to-install-microsoft-net-framework-3-5-offline-in-windows-8-without-internet-connection/
Back to top
View user's profile Send private message
Infralution



Joined: 28 Feb 2005
Posts: 4913

PostPosted: Fri Jul 12, 2013 11:59 pm    Post subject: Reply with quote

I've added an FAQ about this issue.

http://www.infralution.com/phpBB2/viewtopic.php?t=2683
_________________
Infralution Support
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Infralution Support Forum Index -> .NET Encryptor Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group